Package showing install Pending in Primary

(Don’t implement this solution without knowledge of SQL)

ISSUE

Package state displayed as installed in Central and install pending in Primary site. [This issue can randomly occur in larger SCCM environments with large packages and slow WAN links]

Solution

Login to Central Servers and execute the below commands.

Fist command to identiy the packages

select*from PkgStatus

where ID like‘Package ID’

Modify the PackageID, Site code, and server name and execute below command (use the first command output to fill the above details)

update pkgstatus setstatus= 0

where id =‘PackageID’

and sitecode =‘SiteCode’

and Pkgserver =‘ServerName’

Modify the PackageID, Site code, and server name and execute below command (use the first command output to fill the above details)

update pkgstatus set SourceVersion = 0

where id =‘PackageID’

and sitecode =‘SiteCode’

and Pkgserver =‘ServerName’

Now the source version has been changed to 0, so that in the next refresh cycle all the Package version will be deployed to this server.

 Go to central console and refresh the Package for this DP, and observer the log (approximate time for package process required is at least 1 hour)

 

Advertisements
This entry was posted in Troubleshooting. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s